re = /<(LastName)>(.*?)<\/\1>(?![\s\S]*?<\1>\2<\/\1>)/m
str = ' <LastName>Adams</LastName>
<LastName>Adams</LastName>
<LastName>Yellow</LastName>
<LastName>Adams</LastName>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end