#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)^(?!insert|delete|update|procedure) {0,}select.*?;$"
Local $sString = "select 1 from dual;" & @CRLF & _
"" & @CRLF & _
"delete from table where id = " & @CRLF & _
"(" & @CRLF & _
"select 1 from dual" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"update table set id = 1 where id in (" & @CRLF & _
"select 1 from dual);" & @CRLF & _
"procedure dsdsd select fdsfds;" & @CRLF & _
"" & @CRLF & _
"PROCEDURE myproc ()" & @CRLF & _
"IS" & @CRLF & _
"BEGIN" & @CRLF & _
" SELECT" & @CRLF & _
" 1 from dual;" & @CRLF & _
"END AlterarDireito;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")