# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!insert|delete|update|procedure) {0,}select.*?;$"
test_str = ("select 1 from dual;\n\n"
"delete from table where id = \n"
"(\n"
"select 1 from dual\n"
");\n\n"
"update table set id = 1 where id in (\n"
"select 1 from dual);\n"
"procedure dsdsd select fdsfds;\n\n"
"PROCEDURE myproc ()\n"
"IS\n"
"BEGIN\n"
" SELECT\n"
" 1 from dual;\n"
"END AlterarDireito;\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.