import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!insert|delete|update|procedure) {0,}select.*?;$";
final String string = "select 1 from dual;\n\n"
+ "delete from table where id = \n"
+ "(\n"
+ "select 1 from dual\n"
+ ");\n\n"
+ "update table set id = 1 where id in (\n"
+ "select 1 from dual);\n"
+ "procedure dsdsd select fdsfds;\n\n"
+ "PROCEDURE myproc ()\n"
+ "IS\n"
+ "BEGIN\n"
+ " SELECT\n"
+ " 1 from dual;\n"
+ "END AlterarDireito;\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}