# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.{21}\K./<<?>>/gm;t' <<< "This is a test string! Now comes a different one! And yet an another one to demonstrate what I want! Hello there! How can I achieve to replace all exclamation mark to point!"