const regex = /^.{21}\K./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{21}\\K.', 'gm')
const str = `This is a test string! Now comes a different one! And yet an another one to demonstrate what I want! Hello there! How can I achieve to replace all exclamation mark to point!`;
const subst = `<<?>>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);