$re = '/^.{21}\K./m';
$str = 'This is a test string! Now comes a different one! And yet an another one to demonstrate what I want! Hello there! How can I achieve to replace all exclamation mark to point!';
$subst = "<<?>>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;