using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\blink\b.*\blink\b";
string input = @"This link is invalid. Try the link below.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}