package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\blink\b.*\blink\b`)
var str = `This link is invalid. Try the link below.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}