$re = '/\blink\b.*\blink\b/';
$str = 'This link is invalid. Try the link below.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);