const regex = /^(?!.*auth exception).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*auth exception).*$', 'gm')
const str = `This is ok
This is an auth exception
Here's an auth exception in the middle of the string
This is an authoratitive exception, so it's ok
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}