$re = '/^(?!.*auth exception).*$/m';
$str = 'This is ok
This is an auth exception
Here\'s an auth exception in the middle of the string
This is an authoratitive exception, so it\'s ok
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);