re = /^(?!.*auth exception).*$/m
str = 'This is ok
This is an auth exception
Here\'s an auth exception in the middle of the string
This is an authoratitive exception, so it\'s ok
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end