$re = '/^[\w\'\-,.][^0-9_!¡?÷?¿\/\\\\+=@#$%ˆ&*(){}|~<>;:[\]]{2,}$/';
$str = '<InvalidName1>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);