re = /^[\w'\-,.][^0-9_!¡?÷?¿\/\\+=@#$%ˆ&*(){}|~<>;:[\]]{2,}$/
str = '<InvalidName1>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end