#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(<first>|<last>|<state>)"
Local $sString = "<first>Micky</first>" & @CRLF & _
"<last>Mouse</last>" & @CRLF & _
"<state>CA</state>" & @CRLF & _
"" & @CRLF & _
"<first>Donald</first>" & @CRLF & _
"<LAST>Duck</LAST>" & @CRLF & _
"<state>FL</state>" & @CRLF & _
"" & @CRLF & _
"<FIRST>Gyro</FIRST>" & @CRLF & _
"<last>Gearloose</last>" & @CRLF & _
"<state>MA</state>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")