using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<first>|<last>|<state>)";
string input = @"<first>Micky</first>
<last>Mouse</last>
<state>CA</state>
<first>Donald</first>
<LAST>Duck</LAST>
<state>FL</state>
<FIRST>Gyro</FIRST>
<last>Gearloose</last>
<state>MA</state>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}