const regex = /(<first>|<last>|<state>)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<first>|<last>|<state>)', 'gmi')
const str = `<first>Micky</first>
<last>Mouse</last>
<state>CA</state>
<first>Donald</first>
<LAST>Duck</LAST>
<state>FL</state>
<FIRST>Gyro</FIRST>
<last>Gearloose</last>
<state>MA</state>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}