# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<select(?:(?!<\\/select)[\n\s\S])*data-level="2"[\n\s\S]*?<\\/select>//gmU;t' <<< "<div class=\"lsd-search-filter lsd-col-10\">
<label for=\"lsd_search_10574_listdom-location\">Regions</label>
<div class=\"lsd-hierarchical-dropdowns\" id=\"lsd_search_10574_listdom-location_wrapper\" data-for=\"listdom-location\" data-id=\"lsd_search_10574_listdom-location\" data-max-levels=\"2\" data-name=\"sf-listdom-location\" data-hide-empty=\"0\">
<select class=\"listdom-location\" name=\"sf-listdom-location\" id=\"lsd_search_10574_listdom-location_1\" placeholder=\"Select Region\" data-level=\"1\">
<option value=\"\">Select Region</option>
<option class=\"lsd-option lsd-parent-0\" value=\"289\">Region 1</option>
<option class=\"lsd-option lsd-parent-0\" value=\"391\">Region 2</option>
<option class=\"lsd-option lsd-parent-0\" value=\"290\">Region 3</option>
</select>
<select class=\"listdom-location\" name=\"\" id=\"lsd_search_10574_listdom-location_2\" placeholder=\"Select Region\" data-level=\"2\">
<option value=\"\">Select Region</option>
<option class=\"lsd-option lsd-parent-289\" value=\"291\">Area 1</option>
<option class=\"lsd-option lsd-parent-289\" value=\"292\">Area 2</option>
</select>
</div>
</div>"