import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<select(?:(?!<\\/select)[\\n\\s\\S])*data-level=\"2\"[\\n\\s\\S]*?<\\/select>";
final String string = "<div class=\"lsd-search-filter lsd-col-10\">\n"
+ " <label for=\"lsd_search_10574_listdom-location\">Regions</label>\n"
+ " <div class=\"lsd-hierarchical-dropdowns\" id=\"lsd_search_10574_listdom-location_wrapper\" data-for=\"listdom-location\" data-id=\"lsd_search_10574_listdom-location\" data-max-levels=\"2\" data-name=\"sf-listdom-location\" data-hide-empty=\"0\">\n"
+ " <select class=\"listdom-location\" name=\"sf-listdom-location\" id=\"lsd_search_10574_listdom-location_1\" placeholder=\"Select Region\" data-level=\"1\">\n"
+ " <option value=\"\">Select Region</option>\n"
+ " <option class=\"lsd-option lsd-parent-0\" value=\"289\">Region 1</option>\n"
+ " <option class=\"lsd-option lsd-parent-0\" value=\"391\">Region 2</option>\n"
+ " <option class=\"lsd-option lsd-parent-0\" value=\"290\">Region 3</option>\n"
+ " </select>\n"
+ " <select class=\"listdom-location\" name=\"\" id=\"lsd_search_10574_listdom-location_2\" placeholder=\"Select Region\" data-level=\"2\">\n"
+ " <option value=\"\">Select Region</option>\n"
+ " <option class=\"lsd-option lsd-parent-289\" value=\"291\">Area 1</option>\n"
+ " <option class=\"lsd-option lsd-parent-289\" value=\"292\">Area 2</option>\n"
+ " </select>\n"
+ " </div>\n"
+ "</div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}