re = /(\w[\w\.]*)(?=@\w+\.[\w\.]+)\b/m
str = '
I need a regular expression that will match email addresses, but exclude specific email addresses from the match
e.g. do not match;
charlie@outrunthebear.co.uk
mailto: sponge.bob@example.com
jim.bob@example.com
billy.bob@example.com
match all other email addresses;
may be test@example.com or a@b.com a.b.c@d.e.f.com
no.body@example.com
another.test.email@example.com
and.another.one@example.com.au'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end