import Foundation
let pattern = #"(\w[\w\.]*)(?=@\w+\.[\w\.]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I need a regular expression that will match email addresses, but exclude specific email addresses from the match
e.g. do not match;
charlie@outrunthebear.co.uk
mailto: sponge.bob@example.com
jim.bob@example.com
billy.bob@example.com
match all other email addresses;
may be test@example.com or a@b.com a.b.c@d.e.f.com
no.body@example.com
another.test.email@example.com
and.another.one@example.com.au
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)