$re = '/^[^\d]+(\d+)[^\d]+(\d+).*$/';
$str = 'Sie beschleunigen von \'50\' auf \'70\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);