re = /^[^\d]+(\d+)[^\d]+(\d+).*$/
str = 'Sie beschleunigen von \'50\' auf \'70\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end