# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(\d{13}).*|.*/$1/gm;t' <<< "Ceres Juice Apricot 12 x 1lt unit: 6001240102022
Ceres Juice Cranberry& Kiwi Juice 12 x 1lt... unit:
Ceres Juice Guava 12 x 1lt.. unit:6001240222829
Ceres Juice Orange 12x1lt... unit:
Ceres Juice Medley of Fruits 1L x 12 unit: 6001240100660"