#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*(\d{13}).*|.*"
Local $sString = "Ceres Juice Apricot 12 x 1lt unit: 6001240102022" & @CRLF & _
"Ceres Juice Cranberry& Kiwi Juice 12 x 1lt... unit:" & @CRLF & _
"Ceres Juice Guava 12 x 1lt.. unit:6001240222829" & @CRLF & _
"Ceres Juice Orange 12x1lt... unit:" & @CRLF & _
"Ceres Juice Medley of Fruits 1L x 12 unit: 6001240100660"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)