import re
regex = re.compile(r".*(\d{13}).*|.*", flags=re.MULTILINE)
test_str = ("Ceres Juice Apricot 12 x 1lt unit: 6001240102022\n"
"Ceres Juice Cranberry& Kiwi Juice 12 x 1lt... unit:\n"
"Ceres Juice Guava 12 x 1lt.. unit:6001240222829\n"
"Ceres Juice Orange 12x1lt... unit:\n"
"Ceres Juice Medley of Fruits 1L x 12 unit: 6001240100660")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)