import re
regex = re.compile(r"^.*?(rcp\d+).*(_mon\d+).*", flags=re.MULTILINE)
test_str = ("diff_pr_EUR-44_cordex_rcp45_mon_ave_2048-2060_minus_2005-2017_mon10_ave1_withsd.nc\n")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)