re = /^.*?(rcp\d+).*(_mon\d+).*/m
str = 'diff_pr_EUR-44_cordex_rcp45_mon_ave_2048-2060_minus_2005-2017_mon10_ave1_withsd.nc
'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result