package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b((?:[01]?[0-9]|[2][0-3]):[0-5][0-9]\s*[pa]\.?m\b\.?)|\b[ap]\.?m\b\.?`)
var str = `am
pm
P.M.
10:56pm
10:43 a.m.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}