$re = '/\b((?:[01]?[0-9]|[2][0-3]):[0-5][0-9]\s*[pa]\.?m\b\.?)|\b[ap]\.?m\b\.?/mi';
$str = 'am
pm
P.M.
10:56pm
10:43 a.m.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);