import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:[01]?[0-9]|[2][0-3]):[0-5][0-9]\\s*[pa]\\.?m\\b\\.?)|\\b[ap]\\.?m\\b\\.?";
final String string = "am\n"
+ "pm\n"
+ "P.M.\n"
+ "10:56pm\n"
+ "10:43 a.m.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}