using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*) (\d{1,19}) missing data lines in iteration";
string input = @"[2022-05-01 00:00:00] [Thread-1] ERROR MyLoggerName - Iteration #0. [123456, 456789] - 2 missing data lines in iteration
[2022-05-01 00:01:00] [Thread-1] ERROR MyLoggerName - Iteration #1. [234567, 567890] - 951 missing data lines in iteration";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}