re = /(.*) (\d{1,19}) missing data lines in iteration/m
str = '[2022-05-01 00:00:00] [Thread-1] ERROR MyLoggerName - Iteration #0. [123456, 456789] - 2 missing data lines in iteration
[2022-05-01 00:01:00] [Thread-1] ERROR MyLoggerName - Iteration #1. [234567, 567890] - 951 missing data lines in iteration'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end