import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*) (\\d{1,19}) missing data lines in iteration";
final String string = "[2022-05-01 00:00:00] [Thread-1] ERROR MyLoggerName - Iteration #0. [123456, 456789] - 2 missing data lines in iteration\n"
+ "[2022-05-01 00:01:00] [Thread-1] ERROR MyLoggerName - Iteration #1. [234567, 567890] - 951 missing data lines in iteration";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}