package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(#[a-fA-F0-9]+)\s*\|\s*(\S+)`)
var str = `#000000 | Black #ffffff | White #ff0000 | Red`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}