re = /(#[a-fA-F0-9]+)\s*\|\s*(\S+)/m
str = '#000000 | Black #ffffff | White #ff0000 | Red'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end