$re = '/(#[a-fA-F0-9]+)\s*\|\s*(\S+)/m';
$str = '#000000 | Black #ffffff | White #ff0000 | Red';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);