const regex = /[?&]pIds=[^&\n]*$|([?&])pIds=[^&\n]*&/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[?&]pIds=[^&\\n]*$|([?&])pIds=[^&\\n]*&', 'gm')
const str = `?pIds=123,2311
?pIds=123,2311&deal=true
?pIds=123
?pIds=123&deals=true
&pIds=123,2311
&pIds=123,2311&deals=true
&pIds=123
&pIds=123&deals=true`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);