// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[?&]pIds=[^&\n]*$|([?&])pIds=[^&\n]*&").unwrap();
let string = "?pIds=123,2311
?pIds=123,2311&deal=true
?pIds=123
?pIds=123&deals=true
&pIds=123,2311
&pIds=123,2311&deals=true
&pIds=123
&pIds=123&deals=true";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}