import Foundation
let pattern = #"[?&]pIds=[^&\n]*$|([?&])pIds=[^&\n]*&"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
?pIds=123,2311
?pIds=123,2311&deal=true
?pIds=123
?pIds=123&deals=true
&pIds=123,2311
&pIds=123,2311&deals=true
&pIds=123
&pIds=123&deals=true
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)