#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[([0-9]{4}\.[0-9]{2}\.[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2})\] \[([a-zA-Z]+)\] \[(.+)\] \[(.+)\] (.*)"
Local $sString = "[2019.01.10 22:45:37] [INFO] [main] [Config] Starting to load configuration!" & @CRLF & _
"[2019.01.10 22:45:38] [WARN] [main] [Config] Value for key: shard_num was not provided! Using default value: "-1"" & @CRLF & _
"[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: default_prefix was not provided! Using default value: ";"" & @CRLF & _
"[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.server was not provided! Using default value: "https://hastebin.com/documents"" & @CRLF & _
"[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.link was not provided! Using default value: "https://hastebin.com/"" & @CRLF & _
"[2019.01.10 22:45:39] [INFO] [main] [Config] Finished loading configuration!" & @CRLF & _
"[2019.01.10 22:45:43] [INFO] [main] [ShardManager] Login Successful!" & @CRLF & _
"[2019.01.10 22:45:43] [INFO] [main] [Command Manager] Loaded 7 commands in 85ms." & @CRLF & _
"[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-WriteThread] [WebSocketClient] Connected to WebSocket" & @CRLF & _
"[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [JDA] Finished Loading!" & @CRLF & _
"[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [CascadeBot] All shards successfully logged in!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")