import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([0-9]{4}\\.[0-9]{2}\\.[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2})\\] \\[([a-zA-Z]+)\\] \\[(.+)\\] \\[(.+)\\] (.*)";
final String string = "[2019.01.10 22:45:37] [INFO] [main] [Config] Starting to load configuration!\n"
+ "[2019.01.10 22:45:38] [WARN] [main] [Config] Value for key: shard_num was not provided! Using default value: \"-1\"\n"
+ "[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: default_prefix was not provided! Using default value: \";\"\n"
+ "[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.server was not provided! Using default value: \"https://hastebin.com/documents\"\n"
+ "[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.link was not provided! Using default value: \"https://hastebin.com/\"\n"
+ "[2019.01.10 22:45:39] [INFO] [main] [Config] Finished loading configuration!\n"
+ "[2019.01.10 22:45:43] [INFO] [main] [ShardManager] Login Successful!\n"
+ "[2019.01.10 22:45:43] [INFO] [main] [Command Manager] Loaded 7 commands in 85ms.\n"
+ "[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-WriteThread] [WebSocketClient] Connected to WebSocket\n"
+ "[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [JDA] Finished Loading!\n"
+ "[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [CascadeBot] All shards successfully logged in!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}