#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)L.{2}[FR]"
Local $sString = " YMNSMQEML" & @CRLF & _
" FIYRHMFCV" & @CRLF & _
" VLFKFDMFI" & @CRLF & _
" KLLDRFPVA" & @CRLF & _
" RVLDDFTKL" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")