package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)L.{2}[FR]`)
var str = ` YMNSMQEML
FIYRHMFCV
VLFKFDMFI
KLLDRFPVA
RVLDDFTKL
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}