$re = '/L.{2}[FR]/m';
$str = ' YMNSMQEML
FIYRHMFCV
VLFKFDMFI
KLLDRFPVA
RVLDDFTKL
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);