package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{4})([^;]*);([0-9]*)`)
var str = `2008 10example data - (example) - data;200
2014 example data - (example) - data 2;2000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}