re = /([0-9]{4})([^;]*);([0-9]*)/m
str = '2008 10example data - (example) - data;200
2014 example data - (example) - data 2;2000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end