$re = '/([0-9]{4})([^;]*);([0-9]*)/m';
$str = '2008 10example data - (example) - data;200
2014 example data - (example) - data 2;2000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);