import re
regex = re.compile(r"(\/\*[\w\'\s\r\n\*]*\*\/)|(\/\/[\w\s\']*)")
test_str = ("/*api.runTests(true);*/\n"
"//asdfasdf\n\n\n"
"/*\n"
"field.activate(true);\n"
"*\n"
"*/\n\n"
"/*\n\n"
"*/\n\n"
"/****\n"
" * Common multi-line comment style.\n"
" ****/\n"
" \n"
"/****\n"
" * Another common multi-line comment style.\n"
" */")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")